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Chapter 1 

Overview 
 
The Town of Norfolk’s website is powered by the open-source content management system 
(CMS) currently known as Evolution (www.evo.im). It was previously known as MODX Evolution 
until MODX LLC handed off the project. It began development in 2004 and as of writing this 
documentation, Evolution remains an active open-source project with constant upgrades, 
additional features and improved security (current version 1.4.3). 
 
The core structure of Evolution has always remained the same but the interface and plugins 
have continued to evolve. One helpful new feature is the built-in “upgrader” that will alert 
administrators when there’s a new version available and provide an “easy install” button to 
automatically begin the update process.  
 
While it is recommended to apply updates, always use caution as they may introduce an 
unexpected issue. Without an in-depth knowledge of Evolution’s underworkings and/or web 
development this can pose a challenge and why it is important to take advantage of the backup 
module (discussed further in another chapter). 
 
Detailed documentation of the Evolution CMS: 
http://www.evolution-docs.com/documentation/ 

 

http://www.evo.im/
http://www.evolution-docs.com/documentation/


 

Chapter 2 

Elements 
 
Norfolk’s website has been created in such a fashion as to limit the need for editing any of the 
system elements that control what and how content is handled. These include Templates, 
Template Variables, Snippets, Plugins, etc. 
 
On occasion, the Chunks element area may need to be accessed. Chunks are just that, a 
chunk of code (HTML) for the website to display. 
 
The following chunks may need to be edited in the future (when viewing the Chunks tab in the 
CMS, a brief description is provided for each); 

● Contact_Board_of_Selectmen_form 
● copyright 
● footer 
● site-links 
● social 

 
Chapter 3 

Permission Groups 
 
There are two permission types within the CMS. Manager permissions and Web permissions. 
Web permissions are an unused component for Norfolk and should be ignored. 
 
When the website was initially setup, all resources’ Access Permissions were set to Admin to 
lock down all resources. As departments and other entities need access, they will need to have 
a seperate permission group(s) created and then applied to the their resource(s).  
 
Permissions are broken into User Groups and Resource Groups. By separating these two 
areas, the CMS allows a greater control over what users are associated with what resources. 
There is no limit to the number of permission groups that may be associated with a resource 
and/or user, allowing for overlapping of groups. 
 
The most common and simplest way of setting up permissions is to do a 1:1 association. 
 

 



 

To create a permission group called “Technology” for our future “Test” user we will create a 
User Group named Departments - Technology and a Resource Group named Departments - 
Technology. 
 

 
 

 
 
On the User/Resource Group Links tab we will link these two groups so that the user(s) in our 
new user group have access to the resource(s) in our new resource group. 
 

 
If you review the user and resource groups that we created, you will note that Users in group: 
None and Resources in group: None appear. This is normal, as the next chapters will explain 
how to add users and resources to these new groups. 
 
 
 

 



 

Chapter 4 

Users 
 
There are two user types within the CMS. Manager users and Web users. Web users are an 
unused component for Norfolk and should be ignored. 
 
Almost all users will either have a user role of Administrator or General Content Editor. At 
some point in the future, you may find that you need to create a new user role that provides 
more or less access. For example, you may want to give a user the ability to only edit pages, 
not create or delete. Another possible scenario is preventing a user from uploading images or 
files. User roles are configured under Users > Roles. 
 

Tip  |  Administrators automatically have full permission to everything 

 
Previously, in Chapter 3 we setup new permission groups for users and resources. Now it’s time 
to create a new user and add them to the new group. 
 
Under Users > Manager Users we will click New Manager User 
 
You can use either method of password creation, depending on your preference, and you can 
directly send the user an e-mail notification or show it on the screen only for you. 
 
Provide the Full Name of the user, an E-mail address for that user and the User’s role (most 
commonly “General Content Editors”). 
 
The last field(s) that need to be set are under the Access Permissions tab. Select the User 
Group(s) you wish to associate this new user with. In this example, we’re choosing 
Departments - Technology. 
 
Save the new user to finalize the creation. 
 
 
 
 

 



 

Chapter 5 

Resources (permissions) 
 
In Chapter 3 we created permission groups for users and resources. In Chapter 4 we created a 
user and added them to the new user permission group. Now it’s time to add resources to the 
new resource permission group for our user to access. 
 
There are two ways to handle resource permissions. The first, is to go directly to a resource in 
the resource tree and edit the resource. Choose the Access Permissions tab and check off 
what resource group(s) you would like this resource to be a part of. Be sure to save the 
document once you’ve checked off the group(s). Do this with every resource as needed. 
 
The second way is by using the powerful Doc Manager. This feature is further explained in 
Chapter 10. The advantage of the Doc Manager is you can change resource permissions for 
multiple resources at once. This is helpful if you need to change permission for all the resources 
under a specific department. 
 
Using the Doc Manager, choose the Document Permissions tab. Choose a single resource 
permission group, choose whether you’re adding or removing it from the group and then specify 
the range of document IDs you are changing. Remember to click Submit when done. 
 
 

Chapter 6 

File Management 
 
The system configuration page allows administrators to configure the file, image, media and 
flash formats that users can upload. The default settings are the recommended “safe” formats 
and you shouldn’t have to worry about changing them. 
 

Tip  |  When files are uploaded, the CMS automatically performs ‘transliteration’ to clean 
special characters, replace spaces with hyphens and convert to lowercase. 

 
All files uploaded are stored under assets > files, all images uploaded are stored under assets 
> images and media (videos) are stored under assets > media. 
 

 



 

The CMS keeps files, images and media (videos) in separate folders. As such, it is highly 
recommended to maintain a similar folder structure for all. The current folder structure has been 
created to mirror the website’s resources (pages). Since not all departments have images 
and/or files uploaded, their folder will have to be created when the need arises. Any user (with 
access to upload) may create subfolders in the “KCFinder” file viewer by right clicking the parent 
folder that the subfolder is to be created under. 
 
It is imperative that all users keep uploaded files organized and to remove anything that is 
considered outdated. The more “outdated junk” that remains, the harder it is for editors to work 
with files and performing full backups will take longer. 

Manage Files 
Administrators have access to the Manage Files tab located under Elements. This is a root 
directory view of the files on the server and is a simple alternative to using FTP software to 
upload or manipulate the core files. Please use caution as these files are for everything, 
including the files that power the manager! 
 
 

Chapter 7 

Performing Backups 
 
While images and documents are important, the CMS database stores all the actual content of 
the website. If you lose the database you lose your website.  
 

Tip  |  Never rely on your hosting provider for backups as they make no guarantees they’ll be 
able to recover from a disaster, even of their own making. 

Built-in Database Backups 
The CMS has a simple built-in database backup utility located under Tools > Backup tab. 
 
While this tool is “simple” it is by no means useless. This tool enables you to download the 
database to a local disk, restore from a previously downloaded database file and includes a 
helpful snapshot feature for instant backups and restorations. 
 
As an administrator, you must use your own judgement as to how often and in which way you 
want to backup the database. 

 



 

EvoBackup Module 
EvoBackup is an additional module that has been installed in the CMS. This module offers more 
backup options beyond the built-in database backup utility and provides the foundation for an 
automatic backup component. 
 
EvoBackup has the ability to automatically backup any archive level. However, performing a 
“Light Backup” will produce a backup archive that is over 1GB in size and takes a few minutes 
to process. As such, this should only be performed manually and as needed.  
 
As an administrator, you must use your own judgement as to how often and how much you want 
to backup.  
 

Note  |  Full site backups should be performed before an upgrade but choosing “Full Site 
Backup” may take a long time to perform and potentially fail. An alternative is to manually 
backup individual sections such as User Folders as one backup, Elements folders as another, 
etc. 

AutoEvoBackup Plugin 
 
The AutoEvoBackup plugin works with the EvoBackup module and provides an automatic way 
to perform a backup. At this time, it does not have a scheduling feature and relies on manager 
actions (On Logout, On Save, On Login, etc) to initiate the process. 
 
Due to the sheer size and server load that backing up all files requires (over 1GB just for user 
files), it’s recommended to only do automatic updates of the database. The database is usually 
small enough that the process completes almost instantly. 
 
The plugin has been configured to run a backup of the database when a manager user logs in 
and retains a maximum of 20 backups on the server at any given time. These database 
backups are available under the built-in Tools > Backup > Snapshot Save and Recovery tab. 
 
To change settings of the AutoEvoBackup plugin please go to the Plugins tab, 
AutoEvoBackup plugin and then view the Configuration tab. 
 

 
 

 



 

Chapter 8 

Updates 
 
Be sure you’ve performed a full backup! 
 
Updates will unpack new files to the server (overwriting the old ones) and provide an installation 
interface to complete the process. If an update fails to forward you to the installation interface, 
you can manually access it by going to http://norfolk.ma.us/install/ 
 
Follow the onscreen option to perform an upgrade and leave all install settings defaulted to what 
is selected. 
 
After an update is completed, the System Configuration tab will automatically appear when 
you login to the manager. Click Save and the system will perform a final cleanup process. 

After doing an upgrade, confirm the following: 
Plugins > TinyMCE > Configuration Tab 
 
 Custom Style Formats RAW: (BLANK) 
 Custom Style Formats INLINE: (BLANK) 
   

Custom Style Formats BLOCK: 
 
 Attention Box,attention|Alert Box,alert|Help Box,help|Info Box,info|Button,button 
   
 Custom Parameters: 
 
 toolbar_items_size: 'small', body_id : 'content', table_default_attributes: {  'border': '0'  }, 
 
 
   
 Force Paste as Text: enabled 
 
 
 
 

 

http://norfolk.ma.us/install/


 

Chapter 9 

News 
 

● All news is contained under the News container in the resource tree 
● Regardless of the order the news items appear in the manager, the system will always 

present them on the home page by the date/time they were published 
● There are (3) options to choose from - Link, Posting & Article 
● You may add a "News Image" to any of these items, and it will automatically be 

converted into a small thumbnail to accompany your news on the home page 
● Because each news item is like any other resource in the manager, a publish/unpublish 

date may be set to automatically post or remove your news. 
● Be sure to keep things tidy by deleting old news! 

Creating A Link 
● To create a link, right click News and choose Create Weblink here 
● Give it a title based on what the item is 
● If this is a website URL, copy and paste into the Weblink field. Otherwise click Insert 

and upload and/or choose the file you would like to link to 
● Click Save 

 

Creating A Posting 
Postings are for quick notices. Long paragraphs should never be used here. You may include 
links within the posting. 
 

● To create a posting, right click "News" and choose "Create Resource here" 
● Give it a title based on what the item is 
● Type your message in the main content field 
● Click Save 

Creating An Article 
News Articles are meant for very long documents. They may be any length and can include 
photos that will appear on the full article page. You may treat this page like a normal webpage. 
The system will automatically show a limited amount of text and provide a "continue reading" 
link. 
 

● To create an article, right click "News" and choose "Create Resource here" 
● Give it a title based on what the item is 

 



 

● Type your message in the main content field 
● Under the "News" block, for the field "What kind of news is this?" select "News Article" 

(default is set to Posting) 
● Click Save 

 
 
 

Chapter 10 

A Note About Administrator Level Features 

Full Access 
Regardless of whether “Admin” is set under a resource’s permissions, administrators have full 
access at all times to every resource in the CMS. 

Resource Deletion 
The ability to “Permanently purge deleted Resources” is disabled for the General Content Editor 
role. This is to prevent accidental deletion as once a resource is purged, it’s permanently gone. 
Since different users may delete a resource and someone may decide to immediately purge 
their deletion, this would purge any and all deleted resources preventing some users the chance 
to realize and correct their mistake. By shifting this power to administrators only, purging can be 
done at intervals as well as confirming what resource(s) is waiting to be purged. 
 
When there are resources to be permanently deleted, the trash icon will become active.  

 
(icon is inactive, nothing to purge) 

 

Confirming resources to be deleted 
 
The CMS has a log of all Manager Actions under the System 
Settings tab. This gives administrators the ability to see what 
resources have been deleted and by whom.  
 
 
 

 



 

The quickest way to check deleted 
resources is by choosing Deleting 
resource from the Action drop down 
and then doing a search. The results 
will show what documents have been 
deleted, by whom, when, etc. You may 
also view these deleted documents to 
confirm if they should be permanently 
deleted. 
 

Drag & drop resources in the resource tree 
Administrators have a convenient feature that allows dragging and dropping resources around 
the resource tree. This allows you to quickly change the order of the list and even move entire 
containers to new locations. Due to the inherent danger of accidentally moving large groups of 
resources, the system only allows this with the the administrator role. 

Remove Locks 
When a manager user is viewing or editing a resource, their account “locks” that resource. On 
occasion, if a user doesn’t exit a resource once they’re done or the system fails to unlock it, 
administrators can force unlock all resources by clicking Remove Locks under the Tools tab. 

Doc Manager 
The Doc Manager is a powerful bulk editor that enables administrators a streamlined way to 
change specific options of single or multiple resources. Options include templates, template 
variables, permissions, publish dates and more. 
 
You must know the ID number of the resource(s) you want to change. Further instructions on 
how to use the ID number and/or range of ID numbers is provided under the Specify a Range 
of Document IDs field. 

 

 


